Skip to end of metadata
Go to start of metadata

In the Design Studio, you can navigate the UI using the following components:

  1. Main Menu: Access most of the functionality provided by the system.

  2. Main Toolbar: Fast access to commonly used functionality.

  3. Project Tree: Organize and manipulate integration components.

  4. Tab Screens: Screens used to define properties and run tasks.

  5. Transformation Toolbar: Special functions used when creating transformations.


This page explains the Main Menu.

The Main Menu

Here you can access most of the functionality provided by the system using drop-down menus organized into the following categories:

File Menu

  • The File Menu allows you to work with projects and items.
  • Select Open Project to open an existing Integration Project stored on your machine or network.
  • Select New to create a new integration component including: New Operation, New Transformation, New Source, New Target, New Web Service Method, New Web Service Endpoint, New File Format, New Schedule, New Email Message, New Script, New Connect Wizard, or New Project.
  • Select Close Page to close the tab / page that you are currently working on.

Close All Pages - Close all open tabs / pages that you are working on. If a page has unsaved work you will be prompted to save or discard your changes.

Close Other Pages - Close all open tabs / pages except the one that is currently active. If a page has unsaved work you will be prompted to save or discard your changes.

Save - Save the content in the tab / page that you are currently working on.

Save As - Not supported in the current version.

Save All - Save the content in all tabs / pages that you have worked on since they were last saved.

Import Jitterpak - Import Jitterpak from a location on your machine or network.

Export Jitterpak - Export your Integration Project as a Jitterpak.

Download Project [Enterprise Only] - Download a project from a server.

Import Project Data [Enterprise Only] - Import data from another project.

Restore From Backup [Enterprise Only] - Restore project from an automatic backup.

The most recently accessed projects are listed here. The number of items to show is configurable in Edit -> Preferences.

Exit - Close the application.

Edit Menu - work with the files in your Integration Project

  • Undo - undo the work you most recently performed

  • Redo - redo work that you most recently undid

  • Create Copy - create a copy of a particular item

  • Find - search for items in the current project. You can search based on names or field values. You can also search for text in Scripts and Transformation mappings.

  • Trash Can - view the deleted items currently in the Trash Can

  • Preferences - view and modify your client preferences

View - view system utilities and tools. These include:

  • Design - launch the Design Environment in which integrations are defined

  • Administration - access the Administration console

  • Activities Performed - view all of your activities in the environment since you opened the tool

  • Error Log - view any errors that have been reported

  • Known Servers - view a list of all the servers the Jitterbit client is aware of

  • Administration Console - launch the following administration controls:

  • System Console - monitor and change the Jitterbit server you are logged into

  • System Queue - view the operations that are currently running or placed on the queue on the Jitterbit server you are logged into

  • System Operation Log - view the log of all operations that have been executed on the Jitterbit server you are logged into

  • System Operation History - view the history of all operations that have been executed on the Jitterbit server you are logged into

  • Scheduler Console - monitor and change the scheduler of the Jitterbit server you are logged into

  • User Console - manage users and groups

  • Project Console - shows a list of all the projects that you have read permission for

  • Server Logs - allows an administrator to look at the server log files

  • Operation Activity - to get to the following for the operation you are currently working with:

  • Operation Log - view the status of all instances of an operation that have been executed

  • Operation History - view all files processed by an operation

  • Operation Queue - view and modify any pending or active instances of an operation

  • Project Validation - open the project validation view, to see if the project has any items that will fail deployment due to incomplete or invalid definition

  • Project Data Elements - view a list of all the data elements that have been defined in the project

  • Required Plugins - view a list of all the plug-ins that are used by the project. This is available only in the Enterprise Edition.

  • Script Pad - experiment with the Jitterbit scripting language without having to create a new Script in your project.

  • Project Deploy History - view a log of all the times the current project have been deployed to a Jitterbit server

Actions - communicate with a Jitterbit server. This includes:

  • Login - login to a specific server

  • Logout - logout from the current server. Any further server action will require you to specify the user name and password again

  • Update User Profile - update your user profile on the server. This is where a user would change the password

  • Deploy - deploy an Integration Project to a server

  • Test All Connections - test the connection to all Sources and Targets in the current project

  • Refresh All Transformations - refresh all transformations

  • Run Operation - send a request to run the currently selected operation.

  • Set Permissions - control the user and group permissions for the currently selected item.

  • Plugin... - assign plug-ins to the currently selected project item (this option is disabled if plug-ins cannot be assigned to the currently selected item)

  • Stop Current Test - Stop the current test session when stopped at a break-point

  • Resume Current Test - Resume the current test session when stopped at a break-point

Windows - navigate to different Tabs / Items in the system, including:

  • Next Page - go to the next open Tab / Item.

  • Previous Page - go to the previous open Tab / Item.

  • Display Mode - select preferred display mode: Tabs / Floating

  • Recently Closed - select to open a page that was recently closed

  • Windows - go directly to an open Tab / Item.

  • Quick Switch - a searchable list of open Tabs / Items.

Help - information to help you use the Jitterbit Integration Environment

  • Help - launch the help system

  • Jitterbit Support Forum - connect to the Jitterbit Community Forum

  • Jitterbit Quick Start Tutorial - connect to the online Jitterbit Quick Start Tutorial

  • Application Logs - view messages that have been logged by different client components (this is mostly used by Jitterbit developers to track down potential problems)

  • License - view the current status of your Jitterbit license, or request / activate a new license. (This is menu item is not present in the Community version, since Jitterbit Community does not require a license.)

  • About Jitterbit Integration Environment - get information about the current version of Jitterbit you are using

On This Page

Last updated:  May 13, 2018