Skip to end of metadata
Go to start of metadata

WARNING: Standard Edition does not support multiple developers working on the same project. The process outlined in this document is supported in the Professional Edition and Enterprise Edition.

NOTE: This design pattern uses Design Studio as an example; you may apply the same concepts in Cloud Studio using similar steps.

Overview

Team Collaboration within Jitterbit projects requires a single designated individual to serve as the TEAM BUILD Manager. Collaboration within projects also requires that a specific daily process be instituted, every member of the development team to be provided with training to use the process, and for the process to be rigorously followed.

Designated Team Build Manager Process

  • Responsible for consolidating the work of all team members into one TEAM PROJECT and managing the environment structure, project folder structure and migration processes required to do so. 
  • Setting up and modifying Team Configuration. Steps to accomplish this are detailed in the following Example.
    1. Set up the Agent Group and Agent.
    2. Set up TEAM-BUILD Environment
    3. Set up a separate and specifically assigned Environment for each Team Member.
    4. Set up a specific Role for each Team Member with the appropriate access to their specific assigned Environment.
    5. Create the TEAM PROJECT.
      1. Create separate and specifically assigned Folder for each Team Member in the Team Project.
      2. Create common and daily work folders as necessary. 
      3. Deploy the Team Project to the TEAM-BUILD environment in Jitterbit Cloud and select the checkbox for Also store a backup in the Cloud.
      4.  Provide a meaningful tag that will help to identify this version of your integration project (e.g. Project Name, Date Deployed, Version).
    6. Migrate the TEAM PROJECT separately to each Team Member's assigned environment.
    7. Ensure each Team Member Restores the Team Project to their instance of Jitterbit Studio.
  • Ensure each team member understands the TEAM PROJECT folder configuration, the TEAM-BUILD environment configuration and the specific process to develop and deploy their work.
  • Ensure that each team member follows the process rigorously.
  • Ensure that all team members deploy their work at the end of each day to their specific assigned environment.
  • Team Build Manager is the only person that will gather developer changes and migrate those changes into the TEAM - BUILD environment.
  • Daily TEAM-BUILD Migration Steps:
    1. Ensure that all team members have deployed their changes to the cloud.
    2. Open the TEAM PROJECT.
    3. Change the environment to the environment assigned to the Team Member whose code changes you wish to incorporate into the TEAM - BUILD environment.
    4. Select File > Restore Project From Cloud to obtain the latest changes from the developer.
    5. Select File > Migrate Project
    6. Within the project migration wizard, select the TEAM - BUILD environment.
    7. Proceed through the steps of the wizard and select Finish to complete the migration. This will move the latest developer code changes into the TEAM - BUILD environment.
    8. Repeat Steps 1 through 7 of this block of instructions for each Team Member whose changes should be incorporated into the TEAM - BUILD environment.
    9. Deploy TEAM - BUILD environment project to the cloud and select the checkbox "Also store a backup in the Cloud".
    10. Provide a meaningful tag that will help to identify this version of your integration (e.g. Project Name, Date Deployed, Version).
  • Migrate TEAM - BUILD code to a team member's environment when necessary.
  1. All objects located in a common folder should only be modified in the master project and then migrated to user environments.
    1. Notify team members prior to and after modifying a common object.
    2. Test and deploy any changes to a common object prior to notifying your team that changes have been completed.
    3. When notified of a change, allow the notifying team member to complete their change prior to making additional changes.
    4. Obtain the latest changes to any common object as soon as you are able.
  2. Remind the other team members that they are only to use the common objects and may not alter them. If changes need to be made to the objects, the original authoring team member must make the changes and then re-deploy their specific project. 
  3. The TEAM BUILD manager will then migrate the common object change into the TEAM - BUILD environment.
  4. Ensure that the team member that will receive the changed common objects has deployed their latest code to the Cloud.
  5. Change to the each specific Team Member's environment.
  6. Select File > Restore Project From Cloud to obtain the latest version of the Team Member's code.
  7. Change to the TEAM - BUILD environment.
  8. Select File > Migrate Project
  9. Within the project migration wizard, select the same Team Member's environment.
  10. Proceed through the steps of the wizard, selecting the items that you wish to add to the team member's environment, and select Finish to complete the migration. 
  11. This will move the latest common code changes into the Team Member's work environment. 
  12. Change to the same Team Member's environment.
  13. Ensure that the changed common items from the TEAM - BUILD environment are present in the Team Member's project.
  14. Deploy the Team Member's project to the cloud.
  15. Notify the Team Member to restore their project from the cloud to obtain the latest changes.
  16. Repeat Steps 4 through 15 in this block of instructions for each Team Member.

Team Member Process

  • Each Team Member is required to become familiar with the collaboration process and follow the process rigorously.
  • Never make any change to any item located in any folder that is not the Team Member's own specific assigned folder.
  • Each Team Member will perform work only in their specific assigned environment and only within their specific assigned folder.
  • All changes developed in Jitterbit Studio will be placed into the Team Member's assigned folder within each category. Any new operation a Team Member adds to the project must be created within the Team Member's assigned folder prior to deploying the project to the Team Member's assigned environment in Jitterbit Cloud.
  • Team Member will deploy all work to their own specific assigned environment in Jitterbit Cloud at the end of each day.
  • When notified of a change to a TEAM - BUILD common object, the team member will perform the following steps:
    1. Change to the TEAM - BUILD environment.
    2. Select File > Restore Project From Cloud
    3. Select File > Migrate Project
    4. Within the project migration wizard, select Team Member's specific assigned environment.
    5. Proceed through the steps of the wizard, select all of the "Common" folders, and select Finish to complete the migration.
    6. This will move the latest common code changes into  the Team Member's work environment.

Use Case

This document assumes that the user has already downloaded and installed Jitterbit Studio onto their computing device of choice and that the user has Internet access and is able to access the Jitterbit Management Console (https://login.jitterbit.com).

For the purpose of this document we will be setting up a fictional corporation, World Of Wonder, LLC (WOW).  WOW is in the beginning stages of a new integration project. WOW has assigned four employees to the project:

  1. Net Suite who is a NetSuite domain expert;
  2. Sales Force who is a Salesforce domain expert;
  3. SQL Server who is a SQL Server expert; and
  4. Jitterbit Admin, who has prior Jitterbit experience, has been designated as the Team Build Manager.

This team is better known within the WOW organization as the “WOW Integration Team” (WOW IT).  Jitterbit Admin will be the designated person that will be responsible for setting up the project for the other team members.

Example

Steps to Set Up Team Collaboration in the Management Console

  1. Jitterbit Admin logs in to the Jitterbit Management Console.

  2. Select Menu > Agents > Agent Groups.

  3. Click the New Agent Group button in the upper right corner 
    1. Enter a meaningful Name for your new agent group in the Add Agent Group pop-up window.
    2. Click the Save button.
  4. The new agent group displays in the Agent Groups grid.
  5. Select Menu > Agents > Agents.

  6. Click the New Agent button in the upper right corner.
    1. Enter a meaningful Name for your agent in the Add Agent pop-up window. 
    2. Click the Associate Group drop-down arrow and select the Agent Group created in the previous steps to associate with the new agent. 
    3. Click Save.
  7. The WOW Development Agent is displayed in the Agents grid in the following screenshot.
    1. Select the WOW Development Agent in the grid.
    2. Click on Action. Select the appropriate operating system and download the Jitterbit Agent. 
    3. Install the agent on your device of choice.  
    4. During installation, be sure to select the agent that you have set up in the prior steps. In this example that would be WOW Development Agent.
  8. Select Menu > Environments.
  9. Click the Add New Environment button in the upper right corner.
    1. Enter a meaningful Name in the Add Environment pop-up window to create a collaborative team environment in which to build your integration project.
    2. Click the Associate Group drop-down arrow and select the Agent Group created in the previous steps to associate with the new environment.  
    3. Click Save.
  10. Click the Add New Environment button again and repeat steps 9.a. through 9.c. above to create an Environment for each of your team members. The following screenshot is the example for the Net Suite team member.
  11. Click Menu > Organizations
  12. In the lower half of the page, Click the + Add Role button.
    1. Create a role with the WOW IT Project name for each of your team members that will be doing development for this project. In this example, roles were created for WOW IT Jitterbit Admin, WOW IT Project Net Suite, WOW IT Project Sales Force and WOW IT Project SQL Server.
  13. Select Menu > Environments.
  14. Select the Net Suite environment.
  15. In the lower half of the page, click the Grant Role Access.button.
    1. Select WOW IT Project Net Suite from the Select Role drop-down in the Grant Role Access pop-up window.
    2.  As this is the role assigned for team member Net Suite and this is the development environment to be used by team member Net Suite, select all Access methods. Click Save.
  16. Repeat steps 14, 15.a. and 15.b. for each team member environment and the associated team member role for all team members that are working on the WOW IT Project Except for Jitterbit Admin (in this example repeat for Sales Force and SQL Server).  
    1. Jitterbit Admin is already an Admin for the organization, and as such, has full permissions to everything within the organization.  If Jitterbit Admin was not the Organization Admin, it would then be necessary to set up a separate WOW IT Jitterbit Admin role to allow him/her to administer the project.  
    2. Ensure that you only assign permissions for each member to be able to Read, Execute, and Write in their specific associated environment.  Do not assign permissions for a developer to write to any other environment other than their own.  Assigning permissions for a developer in an environment other then their own may allow a developer to overwrite another team member’s work.
  17. Now that all of the collaborative members of the team have a unique role, we can add each individual to their role within the WOW IT Project.
  18. Click Menu > Organizations.
    1. In the Organization grid, ensure that World Of Wonder organization has been selected.
    2. In the bottom half of the page, under Roles / Members, select the first role that has been set up for your team members.  In our example we would select WOW IT Project Net Suite.
    3. Click Action > Add Member.  
    4. Username: Enter the e-mail address of the member that you wish to perform duties within the project using the WOW IT Project Net Suite role in the Net Suite environment. 
    5. Click Save.
  19. This will add Net Suite to their new role and allow them to have access to the project within their environment.  

    NOTE 1: Since we only added their role to their environment, Net Suite will not have access to any other environment based on having followed the steps in this example.

    NOTE 2: This should be verified by Jitterbit Admin to reduce the likelihood of Net Suite accidentally overwriting another team member’s work.  

    NOTE 3: If you have more than one member of the team that will contribute to a specific area of the project, for example two SQL Server developers, you should create separate roles and environments for each of those members so that one may not accidentally open the other members environment and overwrite any of their work.

  20. Keeping environments separate for each member of the team is of the utmost importance.
  21. Repeat this process for each current member of the team.  Repeat this process for each new team member at the time they are added to the team.

Steps to Set Up Team Collaboration in Jitterbit Studio

  1. Jitterbit Admin launches Jitterbit Studio and logs in.
  2. Click on the New Project tab.
    1. Enter an appropriate new Project Name.
    2. Verify the Location is correct. If not, click the Browse button and navigate to the correct location.
    3. Click the Environment drop-down and select WOW IT Build for the environment.  
    4. Click the Create button.
  3. The WOW IT Project displays as an empty project.
  4. OPTIONAL: If you wish to create a standard template for your team folder structure you may do so at the Operation level.  When done you may then right-click on Operations in the tree on the left and select Duplicate Folder Structure To… and then select each appropriate area in which you want to have the folder structure duplicated.
  5. HIGHLY RECOMMENDED: Create a folder under Operations that is named Common.  Follow the instructions in Steps 6.a and 6.b to do so.  This would be a location in which work would be intentionally shared among members of the team.  A Global Variable file that contains Project variables that are needed by all team members would be an example of why you may want to include a Common folder. In this example, the Common folder has been created.  A generic Operation named Daily Work has also been created within the Common folder. The Daily Work operation will be used later in the this example in the Migrate Team Project to Team Member Environments section.
    .
  6. REQUIRED: Create a folder structure for each member of the team under Operations.
    1. In the tree on the left, right-click on Operations and select New Folder.
    2. Enter the new folder Name in the pop-up field and press Enter.  In this example a folder is created for the team member Net Suite.
    3. Repeat steps 6.a. and 6.b. for each team member .
    4. The team member folders display underneath Operations in the tree on the left.
  7. HIGHLY RECOMMENDED: Add a “Newly Added” work folder under each team member’s folder.  By doing so and asking each team member to place all of their new or modified work into this folder, it will be much easier for Jitterbit Admin to know what work needs to be incorporated into the WOW IT Build environment each day.  This will aid substantially in making it less likely that any work may be lost or overwritten.
    1. Right-click on the Net Suite folder
    2. Enter Newly Added in the pop-up field and press Enter.
    3. Repeat Steps 7.a. and 7.b. for each team member folder.
    4. The Newly Added folder displays under each team member folder.

How to Copy a Folder Structure From One Project Destination Type to Additional DestinationTypes

  1. Once the folder structure for your project is completed, you may choose to copy that structure to other project element destination types within Jitterbit Studio. In the tree on the left, right-click on Operations and select Duplicate Folder Structure To… from the list.
  2. Click the associated checkbox to select each project element Destination Type within the project to copy the file structure into.
  3. You may select none, one, many, or all of the distinct areas within the project to copy your newly created folder structure to.  
  4. You may always add additional destination types to copy the folder structure to later if needed.  
  5. Once you have selected the appropriate destination types, click OK to have your Operations folder structure duplicated within the selected types.

Deploy Project With Team Collaboration File Structure to Cloud

  1. Once the collaboration file structure is completed, it is recommended that the project administrator deploy all of the changes to the Jitterbit Cloud for safekeeping and version control.
  2. Click on the Deploy  icon from the top level menu bar, or right-click on the Project, as shown in the image below, and select Deploy.

  3. The Deploy: WOW IT Project screen displays.
  4. Select Everything.
  5. Select the Also store a backup in the Cloud checkbox.It is important to be able to roll back changes to the project from a backup.
  6. Enter an appropriate label in the text box to identify what the specific backup contains, such as what, when and version. In this example, the label includes the project name (WOW IT Project), the date it is being deployed and backed up (01/01/2016) and a version value (Version Original) that will help to identify the state of the project that the backup contains.
  7. Click the Deploy button.

Migrate Team Project to Team Member Environments

  1. At this point, Jitterbit Admin has created a new team project.  However, if any of the team members log in to Jitterbit Studio, they will not have the ability to open the WOW IT Project.  That is because the project was deployed by Jitterbit Admin into his own assigned environment and the other team members do not have access to Jitterbit Admin’s environment. In this example, the Jitterbit Admin environment is acting as the TEAM-BUILD Environment and Jitterbit Admin is acting as the Team Build Manager, as described in the Overview above.  Only Jitterbit Admin should have access to the Jitterbit Admin environment and will be responsible for consolidating the work of all team members into one WOW IT Project within this environment. In order to get the other team members started, Jitterbit Admin needs to migrate the WOW IT Project to each team member’s assigned environment.
  2. In the next step you will migrate the WOW IT Build project into each team member’s environment.  Before doing so, it will be necessary to drag and drop an operation into the team member's assigned folder.  In this example, we have moved the Daily Work operation from the optional Operations > Common folder into the  the Net Suite > Newly Added folder.  By doing so you will force the migration to include your folder structure as part of the project migration.  Folders that do not contain anything are excluded from the migration process.  By moving the Daily Work operation into your folder stucture, you are forcing the migration process to include your folder structure.
  3. Right-click on the WOW IT Project and select Migrate from the drop-down list.
  4. The Project Migration wizard dialog displays.  Ensure that you are migrating from the correct environment (WOW IT Build) into the correct environment (Net Suite).
  5. In this example, we are attempting to migrate the WOW IT Project from the WOW IT Build environment into the Net Suite environment that is using the Agent Group: Development Agent Group.  As this all seems to be correct, click Next and proceed through the wizard until the Finish button becomes enabled.
  6. The Confirmation Migration screen shows you what is about to happen.  It shows what will be inserted in the top portion of the screen and it shows you what will be overwritten in the bottom portion of the screen.
  7. In this example the information is correct. Click the  Finish. button
  8. Repeat Steps 2 through 7 in this section for the folder assigned to each member of the team (Sales Force, SQL Server). Now each member of the team will have access to the project within their assigned environment.  Have each member of the team log in to Jitterbit Studio and verify that they are able to open the project within their environment.

Team Member Begins to Develop in Jitterbit Studio

  1. Team member Net Suite logs in to Jitterbit Studio, selects the WOW IT Project and clicks on the Open button.
  2. Each member of the team should see the WOW IT Project in their specific context.  The following would be the expected view for Net Suite.


  3. Net Suite’s first task is to copy the Operations folder structure to all other project element destination types within the environment.  
  4. Net Suite selects the checkbox for several destination types and clicks on the OK button.
  5. The Common and Net Suite > Newly Added folders now display under the selected destination types in Net Suite's environment, as shown in the following image.


  6. Net Suite is then tasked with creating a new operation that will create a file.  The file will then be read and transformed into a new file.
  7. Net Suite right-clicks on the Net Suite > Newly Added folder and chooses New Operation of type Transformation and clicks Continue.  Net Suite finishes creating the Create File and Modify User Name File operations, deploys the project to his assigned environment in the cloud, and finishes working for the day.
  8. Jitterbit Admin wants to incorporate the changes Net Suite developed into the WOW IT Build environment.  
    1. Jitterbit Admin logs in to Jitterbit Studio and selects Net Suite in the Environment drop-down list in the upper left corner.
    2. Select File > Restore Project From Cloud to obtain the latest changes from the developer.
    3. Jitterbit Admin reviews the Create File and Modify User Name File operations, the Transform User Name File transformation, the Modified User Name File source and the Modified User Name File target that Net Suite has completed.  Jitterbit Admin can see all of the work completed by Net Suite, as shown in the following image.
  9. Jitterbit Admin can see that Net Suite has made changes to the WOW IT Project in the Net Suite environment.  In order to move and consollidate the changes into the WOW IT Project, Jitterbit Admin must now migrate the Net Suite environment into the WOW IT Build environment.
  10. The safest and best method for moving work from a team member's working environment into the WOW IT Build environment and thereby consolidating the work into the WOW IT Project, is to migrate items from the Newly Added folders.  Generally this can be achieved by right-clicking on each new Operation in the team member’s Newly Added folder and choosing Migrate
  11. The Migration Wizard displays.  Continue through the wizard until the Finish button becomes enabled.  You should see the Confirm Migration window as shown in the following image..
  12. The upper portion shows the changes that will be inserted into the WOW IT Project, while the bottom portion shows the changes that will be overwritten in the project.
  13. It is extremely important to fully review the information in this window to validate that these changes make sense and be absolutely certain that you are not about to overwrite existing work that should not be overwritten.  This is the critical step in the process to avoid making a mistake and potentially losing work that has already been added to the build environment.  In this case, since all of the work to be inserted is located under Net Suite’s Newly Added folders and nothing is to be overwritten, we should be safe to complete the migration.
  14. Click Finish.
  15. Repeat this process for each of the operations in the Operations > Newly Added folder.  It may be helpful to move each item from the Newly Added folder to the Net Suite folder once the migration has been completed for each operation.  This process provides a way to track each operation that has already been moved and to know when you have finished migrating all of the changes.
On This Page

Last updated:  Apr 19, 2019